SVERWEIS auf Daten mit einem anderen Datenformat machen

Angelegt Freitag 06 November 2020

Es ist ein typisches Problem: Man will einen SVERWEIS machen, aber leider stimmen die Datenformate nicht ganz zusammen. Mir passiert es z.B. häufiger, dass ich aus einer Quelle zehnstellige Kundennummern mit zwei vorgestellten Nullen als Text formatiert bekomme und aus der anderen Quelle achtstellige Kundennummern ohne vorgestellte Nullen.

Ich kann ich die hintenstehenden Ziffern natürlich auch direkt mit dem Befehl "RECHTS(ZELLE;8) abgreifen, aber das ist auch etwas häßlich und führt v.a. dazu, dass ich die Zahlen trotzdem noch als Text vorliegen habe.

Daher bietet es sich an, die Transformation direkt im SVERWEIS durchzuführen. In diesem Fall kann ich auch eine VERKETTEN-Funktion in den SVERWEIS einbauen, um direkt die beiden Varianten zu verbinden:

=SVERWEIS(VERKETTEN("00";ZELLE);MATRIX;SPALTE)

Oder um es einfacher zu sagen: der SVERWEIS nimmt auch eine Formel als Suchkriterium an. Und damit kann ich sehr feine Operationen durchführen - ein "Trick" ist es z.B. eine als Text formatierte Zelle als ZELLE*1 anzusprechen. Dann arbeitet sie als Zahl. Zudem kann ich natürlich mit den Eingangswerten auch rechnen oder andere Textformatierungsoptionen direkt im SVERWEIS durchführen.

Nachteil ist, dass die Formel irgendwann herzlich unübersichtlich wird, gerade wenn ich noch die #NV abfangen will. So ist folgende Formel nicht gerade allgemeinverständlich:

=WENN(ISTNV(SVERWEIS(VERKETTEN("00";$F4);Kaufend!$A:$Q;5;FALSCH));"0";SVERWEIS(VERKETTEN("00";$F4);Kaufend!$A:$Q;5;FALSCH))

Es bietet sich also an, eine passende Dokumentation zu erstellen.




Backlinks: Technik:Excel